13 december 2021

Log4j kwetsbaarheid

Afgelopen vrijdag is een ernstige kwetsbaarheid in de populaire log4j tool voor Java applicaties bekend gemaakt. Deze kwetsbaarheid stelt aanvallers heel eenvoudig in de gelegenheid om kwaadaardige code te draaien op kwetsbare servers.

Bij iXL Hosting draait maar weinig software op Java. De primaire systemen (Webservers, Mailservers, FTP servers, SSH servers) zijn geen van allen Java. Hierdoor is onze verwachting dat deze kwetsbaarheid geen grote impact heeft op ons. Een aantal secundaire systemen zoals Elasticsearch zijn wel Java. We zorgen dat al deze systemen voor maandagmiddag 17:00 gepatcht zijn. Dit kan zorgen voor een korte onderbreking in de dienstverlening.

Update 13:40: Alle systemen van HostingXS zijn inmiddels gepatcht.

Update 14:20: Openxchange (appsuite) en Zimbra zijn niet kwetsbaar

Update 16:15: We zijn vrijwel klaar met het patchen van alle systemen

Update 17:00: We zijn klaar met het patchen van alle systemen